First of all HI GUYS!! My name is Sergey and i'm from Russia... in this way sorry for my ENGLISH....
I have big troubles with geodate on my server..... I compiled server using instructions...(version 2316) i created maps, vmaps... By using .bat file with
vmap_extractor.exe -d data
md vmaps
vmap_assembler.exe buildings vmaps
pause
AND MAPS, and VMAPS created without of ERRORS!!! Folder with VMAPS has 6126 files and it weighs 353 megabytes!
PunBB bbcode test
PunBB bbcode test
Server started without errors, and spell work correctly!! Thank U oregoncore!!! BUT!!! I don't understand.... WHAT... WITH!! GEODATA!!! When i use charge my character behaves like a madman!!! As PROOF i capture video.... Someone help me... Where the problem?!?!? In oregoncore?! In my vmaps?! In my HANDS?!?!? I don't know!....
http://youtu.be/citU3vqg82o

p.S. in oregoncore.conf i use next config
vmap.enableLOS = 1
vmap.enableHeight = 1
vmap.ignoreMapIds = ""
vmap.ignoreSpellIds = "7720"
vmap.petLOS = 1
vmap.totem = 0
vmap.enableIndoorCheck = 1
DetectPosCollision = 1
TargetPosRecalculateRange = 1.5
mmap.enabled = 1
mmap.ignoreMapIds = ""

It seems not the right way. The player must pass through the rope.

You can even try how will behave  Hunter pet with this place. I think that the pet is stuck on a rope big_smile

Yes... Pets not normally TOO!! They can lose agro at any time and escape to the owner.... Tell my please do u have this erros and anomalies with geodata?! And how i can fix this?!??! Where the problem? I don't know.... i recompile server more then 10 times... and vmaps/maps.... I try to disable vmaps heights in config... and i try other settings.... All without success...

Flywithme wrote:

It seems not the right way. The player must pass through the rope.

You can even try how will behave  Hunter pet with this place. I think that the pet is stuck on a rope big_smile

These problems occur not only in this location....(((

Really only i encountered with this problem?!?!?! I can't believe..

I do not think so.

Wait for an answer from the developer smile

P.S Read private message

Hey, have you tried this with mmaps? I might give it a whirl tonight after I get back from work. If it's still broken with those I'll have a proper good look. I know there's a way to extract specific mmap files too so you can only pull blades edge arena etc.

But the video is proof enough smile English is great by the way, good job.

LordUsagi wrote:

Hey, have you tried this with mmaps? I might give it a whirl tonight after I get back from work. If it's still broken with those I'll have a proper good look. I know there's a way to extract specific mmap files too so you can only pull blades edge arena etc.

But the video is proof enough smile English is great by the way, good job.

I use MMAPS and VMAPS, and ofcourse i enable settings(such as vmap.enableLOS = 1 and mmap.enabled = 1)
in config!!!  And i tried to switch off some settings... the result was bad.
P.S. GEODATA everywhere works badly!!! But at blades edge arena it works just awful.... Can u TEST geodata and tell me do u have same problems...   May be i do something wrong... I hope for it...

LordUsagi wrote:

Hey, have you tried this with mmaps? I might give it a whirl tonight after I get back from work. If it's still broken with those I'll have a proper good look. I know there's a way to extract specific mmap files too so you can only pull blades edge arena etc.

But the video is proof enough smile English is great by the way, good job.

So i recreate vmaps and maps.... recompile the core and THIS problem don't repeated... GEODATA not ideal but normal... But now i saw the problem with mage's blink.... For example IF before mage the rise blink not work... and IF mage hasn't 20 yards to blink he dont blink... I think that if u hasn't 20 yards u should blink to the obstacle... BRRRR.... Sorry for my ENGLISH.... and see the movie... blink work correctly only at straight...
PROOF LINK!
http://www.youtube.com/watch?v=w3L7Ornc … e=youtu.be

10 (edited by Langer 2014-11-03 09:01:34)

Hello, I have the same problem. Mage Blink works only in the main cities, houses or in the instances. Also fishing only works in the main cities. Outside the cities, there is not even the drowning does not go outside. I Mmaps, vmaps and dbc extracted. but without success.

The world map does not work, the discovered areas are not displayed, the map remains undetected. In the cities, the card works
Sry for my english

All this works for me. Blink, Fishing and the Map works every where. On a NON-GM character.

LordUsagi wrote:

All this works for me. Blink, Fishing and the Map works every where. On a NON-GM character.

Yes, all this works. Blink works in instancen and cities. But not with me at the quests so outside. Fishing exactly the same problem. can not find the error, please help

13 (edited by desteny 2014-11-04 13:58:39)

To fix the problem with charge on ropes for example blades edge arena, its needed to add offmesh connections to the mmaps data.
this can be done by using the example in https://bitbucket.org/oregon/oregoncore … at=default

this must be added to the extractor script by using the parameter and then it generates the connections in your mmaps file.

for example blades edge arena:
562 31,20 (6234.545898 256.902100 11.075373) (6230.961914 252.127274 11.180979) 8 // Blade's Edge Arena
562 31,20 (6243.081543 266.918854 11.059557) (6246.507324 271.623505 11.230524) 8 // Blade's Edge Arena

add this to your offmesh file and reextract it and charge will work!


about Blink, i think youre using the wrong spell, cause blink mage spell is different and cause of the not 100% correct implemnetation of blinking spell groups it works maybe only for the real blink.

but btw. don't know if the OC team has refactored blink on ramps (Z level blink) but in older versions it was not correct

Not yet, but I've got my eye on someones work with the spell and it looks really promising.

desteny wrote:

To fix the problem with charge on ropes for example blades edge arena, its needed to add offmesh connections to the mmaps data.
this can be done by using the example in https://bitbucket.org/oregon/oregoncore … at=default

this must be added to the extractor script by using the parameter and then it generates the connections in your mmaps file.

for example blades edge arena:
562 31,20 (6234.545898 256.902100 11.075373) (6230.961914 252.127274 11.180979) 8 // Blade's Edge Arena
562 31,20 (6243.081543 266.918854 11.059557) (6246.507324 271.623505 11.230524) 8 // Blade's Edge Arena

add this to your offmesh file and reextract it and charge will work!


about Blink, i think youre using the wrong spell, cause blink mage spell is different and cause of the not 100% correct implemnetation of blinking spell groups it works maybe only for the real blink.

but btw. don't know if the OC team has refactored blink on ramps (Z level blink) but in older versions it was not correct

I'm actually giving this a shot right now as the fix is still not implemented to the default repo.

Ex owner of Sumiagaming.com , returning for some new TBC action.

don't know why this is not added to the repo O.o maybe i make a pull request later

I think know i can't see this problem......

should be added here https://github.com/OregonCore/OregonCor … actor/Info and maybe add the parameter --offMeshInput by default to the OC script.

(or make a change and add this 3 lines of data to thge extractor it self as constant

btw: on a other topic someone shared some more connections or i remember false?

should be added here https://github.com/OregonCore/OregonCor … actor/Info and maybe add the parameter --offMeshInput by default to the OC script.

(or make a change and add this 3 lines of data to thge extractor it self as constant)

btw: on a other topic someone shared some more connections or i remember false?