Hey fellows,

I tried to build and run oregon core with docker.
In the attachement you can find my files for that.

For the database and the realm it works fine.
But the core crashes everytime on startup. It does not write any logs neither printing out any error.

Any ideas, what that could be about?


Don't wonder: in the compose file, the default command of the core is overwritten for easier debugging.

2 (edited by oregon88 2019-05-21 09:15:11)

I was able to reproduce a similar error on a VM.
There it created a log entry in db_errors.log which says:
"Loaded 0 Oregon strings. DB table oregon_string is empty. Cannot continue."

Any ideas, what's the issue?

have you imported the big database file (world DB?)
https://github.com/OregonCore/OregonCore/releases

it seems like you have no entries in "oregon_string" table

4 (edited by oregon88 2019-05-26 19:38:18)

You were absolutely right!
I tired to fill the database by using:

mysql -r root -p world < OregonDatabase.sql 

There was no error, but after now checking the tables, I noticed, there were none.
The issue was the default max_allowed_packet size configured by mysql.
After increasing that by using the following statement:

SET GLOBAL max_allowed_packet=1073741824;

it worked fine.

The issue with getting no logs was I forgot to create a folder logs which was configured as the location for those *facepalm*

I am now struggeling with an error while updating database. It says for 2019_05_08_01_hellfire_peninsula.sql,

Truncated incorrect DOUBLE value: '18950 0'

I will check, if this error only happens when using MariaDB instead of MySQL and let you guys know as I got more details.

I checked it and got it working using mysql:5.5 as docker image for the database instead of mariadb.