1 (edited by xsoja 2016-05-17 03:50:35)

Im on the Step 
Configuring and generating Visual C++ solutions with CMake

Before you begin, create an empty directory called build. In this example, we will use D:\build 

but I am getting this error (see imgur pic below)
http://imgur.com/kAzlvjS

Windows 7 64 bit Pro
CMake 3.5.2
Visual Studio - 14.0.25 (update 2)

here is the error output file

Compiling the C compiler identification source file "CMakeCCompilerId.c" failed.
Compiler: 
Build flags:
Id flags:

The output was:
1
Microsoft (R) Build Engine version 14.0.25123.0
Copyright (C) Microsoft Corporation. All rights reserved.

Build started 5/16/2016 8:03:24 PM.
Project "C:\OregonCore\Build\CMakeFiles\3.5.2\CompilerIdC\CompilerIdC.vcxproj" on node 1 (default targets).
C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Platforms\Win32\PlatformToolsets\v140\Toolset.targets(34,5): error MSB8036: The Windows SDK version 8.1 was not found. Install the required version of Windows SDK or change the SDK version in the project property pages or by right-clicking the solution and selecting "Retarget solution". [C:\OregonCore\Build\CMakeFiles\3.5.2\CompilerIdC\CompilerIdC.vcxproj]
Done Building Project "C:\OregonCore\Build\CMakeFiles\3.5.2\CompilerIdC\CompilerIdC.vcxproj" (default targets) -- FAILED.

Build FAILED.

"C:\OregonCore\Build\CMakeFiles\3.5.2\CompilerIdC\CompilerIdC.vcxproj" (default target) (1) ->
(Desktop_PlatformPrepareForBuild target) ->
  C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Platforms\Win32\PlatformToolsets\v140\Toolset.targets(34,5): error MSB8036: The Windows SDK version 8.1 was not found. Install the required version of Windows SDK or change the SDK version in the project property pages or by right-clicking the solution and selecting "Retarget solution". [C:\OregonCore\Build\CMakeFiles\3.5.2\CompilerIdC\CompilerIdC.vcxproj]

    0 Warning(s)
    1 Error(s)

Time Elapsed 00:00:00.40


Compiling the CXX compiler identification source file "CMakeCXXCompilerId.cpp" failed.
Compiler: 
Build flags:
Id flags:

The output was:
1
Microsoft (R) Build Engine version 14.0.25123.0
Copyright (C) Microsoft Corporation. All rights reserved.

Build started 5/16/2016 8:03:25 PM.
Project "C:\OregonCore\Build\CMakeFiles\3.5.2\CompilerIdCXX\CompilerIdCXX.vcxproj" on node 1 (default targets).
C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Platforms\Win32\PlatformToolsets\v140\Toolset.targets(34,5): error MSB8036: The Windows SDK version 8.1 was not found. Install the required version of Windows SDK or change the SDK version in the project property pages or by right-clicking the solution and selecting "Retarget solution". [C:\OregonCore\Build\CMakeFiles\3.5.2\CompilerIdCXX\CompilerIdCXX.vcxproj]
Done Building Project "C:\OregonCore\Build\CMakeFiles\3.5.2\CompilerIdCXX\CompilerIdCXX.vcxproj" (default targets) -- FAILED.

Build FAILED.

"C:\OregonCore\Build\CMakeFiles\3.5.2\CompilerIdCXX\CompilerIdCXX.vcxproj" (default target) (1) ->
(Desktop_PlatformPrepareForBuild target) ->
  C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Platforms\Win32\PlatformToolsets\v140\Toolset.targets(34,5): error MSB8036: The Windows SDK version 8.1 was not found. Install the required version of Windows SDK or change the SDK version in the project property pages or by right-clicking the solution and selecting "Retarget solution". [C:\OregonCore\Build\CMakeFiles\3.5.2\CompilerIdCXX\CompilerIdCXX.vcxproj]

    0 Warning(s)
    1 Error(s)

Time Elapsed 00:00:00.40

I would just like you guys to know I fixed the problem, the issue was not installing c++ with visual studio.

I can't figure out how to delete this post.

What version are you using of Visual Studio ?
2012 ? 2015 ?

Using version 2015